OAuth secrets containing C.* expressions fail to resolve during authentication

Incident Report for Cribl

Resolved

This incident has been resolved.
Posted Aug 21, 2026 - 08:30 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2026 - 18:49 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release. A fix has been prepared and will be deployed as part of a rolling upgrade.

Your organization will be picked up for upgrade on a rolling basis between 01:45 and 05:45 UTC on August 21, 2026 (9:45 PM – 1:45 AM EDT, Aug 20–21). Once the upgrade begins for your tenant, it will take approximately 20 minutes to complete.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443): https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.
Posted Aug 20, 2026 - 18:47 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release and are preparing to deploy a new version to remediate the issue.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443). https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.

Next Update: Will occur at the top of the hour or as soon as fix deployment begins.
Posted Aug 20, 2026 - 18:00 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release and are preparing to deploy a new version to remediate the issue.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443). https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.

Next Update: Will occur at the top of the hour or as soon as fix deployment begins.
Posted Aug 20, 2026 - 17:00 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release and are preparing to deploy a new version to remediate the issue.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443). https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.

Next Update: Will occur at the top of the hour or as soon as fix deployment begins.
Posted Aug 20, 2026 - 16:10 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release and are preparing to deploy a new version to remediate the issue.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443). https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.

Next Update: Will occur at the top of the hour or as soon as fix deployment begins.
Posted Aug 20, 2026 - 15:00 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release and are preparing to deploy a new version to remediate the issue.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443). https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.

Next Update: Will occur at the top of the hour or as soon as fix deployment begins.
Posted Aug 20, 2026 - 14:02 PDT

Update

We are actively working on a resolution for the issue affecting OAuth secret fields following the v4.19.1 release and are preparing to deploy a new version to remediate the issue.

For full details and temporary workarounds, please review our published Known Issue (CRIBL-44443). https://docs.cribl.io/results/?searchOption=known-issues&tickets=CRIBL-44443

If you have additional questions or require assistance, please contact our support team at support@cribl.io.

Next Update: Will occur at the top of the hour or as soon as fix deployment begins.
Posted Aug 20, 2026 - 14:01 PDT

Update

We have identified the root cause of the issue impacting OAuth secret fields following the v4.19.1 release. Our engineering team is actively working on a resolution.If you are experiencing this issue or require assistance, please reach out to our support team at support@cribl.io.

Next Update: In 1 hour or as soon as new information becomes available.
Posted Aug 20, 2026 - 13:01 PDT

Update

We have identified the root cause of the issue impacting OAuth secret fields following the v4.19.1 release. Our engineering team is actively working on a resolution.If you are experiencing this issue or require assistance, please reach out to our support team at support@cribl.io.

Next Update: In 1 hour or as soon as new information becomes available.
Posted Aug 20, 2026 - 12:12 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 20, 2026 - 11:13 PDT